Archiv

Extruder

Auf Ebay gab es günstig einen E3D V5 Hotendbausatz zu ersteigern, ursprünglich hatte ich das mal für Dual-Extruder Druck vorgesehen, aber das liegt erstmal auf Eis. Nichtsdestotrotz kann man damit ja noch etwas Anfangen.

Zu ersteigern gabs den Hotendbausatz inklusive drei verschiedener Düsen, für knapp 25 Euro.

E3D_V5_KitVon den drei Düsen werde ich die 0,35mm nutzen, mit einer 0,25mm Düse dürfte drucken ja ewig dauern. Die 40W 12V Heizpatrone habe ich durch eine 24V Typ ersetzt.

P1060857Der Zusammenbau ist einfach, nur der Teil mit dem NTC und dem Fiberglas verstärkten Kabel ist etwas kniffliger. Ich muss doch mal nach einem 300°C temperaturfestem Wärmekleber ausschau halten, den NTC einfach so los zu haben gefällt mir nicht.

P1060855Die Kabel habe ich mit Steckern und Buchsen versehen, damit lässt sich der Extruder leicht tauschen.

P1060859Da ich aber keine Extruder mit 16mm Aufnahme hatte, habe ich einfach mal einen Adapter gedruckt um damit mal etwas herumzuspielen. Beim ein paar ersten Tests ist mir aufgefallen das der 30mm Lüfter recht laut ist, den sollte ich durch einen 40mm Lüfter ersetzten, Adapter dafür gibts schon auf Thingiverse. Mit bis zu 300°C Extrudertemperatur kann man auch die verschiedensten Materialien drucken, könnte lustig werden. Ansonsten gefällt mir so ein all metal Hotend doch ganz gut, für einen ausführlichen Test muss ich damit aber erstmal noch mehr Drucken.

Wenn der neue Extruder einfach nicht richtig Drucken will, und man die Temperatur übertrieben hoch einstellen muss, damit es funktioniert, sollte man mal die „echte“ Temperatur messen.

Repetierhost: Saubere 240°C über schon einige Minuten

P1060774Mit einem ordentlichem Typ K Temperaturfühler mal an der Düse nachgemessen:

tempDas sind 16°C Temperaturdifferenz, kein Wunder das bei 215°C im Repetierhost sich das ABS nicht ordentlich schmelzen lies, und ich erstmal die Temperatur hochschrauben musste.

Gibt es den in Marlin eine Option für einen Temperatur Offset?

Spannungsteilermodifizierung

Ich habe Spaßeshalber mal einen der 4k7 Widerstände am Spannungsteiler des NTCs durch einen 1k Widerstand ersetzt, die Firmeware geändert, und schon zeigt Repetierhost 231°C an. Die doppelte Auflösung macht sich also bemerkbar.

Das ist schon deutlich näher dran, und bleibt auch näher am gemessenem Ergebniss dran wenn ich andere Temperaturwerte probiere. Der 1k Widerstand bleibt also drin, und weil ich grade schon dabei war kurz mal die Spannung am Spannungsteiler nachgemessen, etwas rumgerechnet und mit der Tabelle (thermistortables.h) für die Temperaturen im Marlin verglichen. Resultat, jupp die Spannung die ich messen kann passt ganz gut zu der Tabelle und damit zu den angezeigten Temperaturen.

Für den Fall das, das jemand nachmachen möchte:

Extruder auf eine bestimmte Temperatur aufheizen, dann schnell den Thermistor für den Extruder auf Ramps abziehen und den Widerstand messen. Marlin wird dann zwar eine Fehlermeldung ausspucken und den Heizvorgang abbrechen, aber man hat ja den Widerstandswert dann ja schon bestimmt.

Bei 200°C sind das bei mir 561 Ohm.

Anschließen mal in Datenblatt zum Thermistor nachgucken. Bei mir ein 100k EPCOS, für 200°C sollte der nominale Widerstand 557,6 Ohm sein. Das passt also hervoragend und liegt noch prima in dem 1% Toleranzbereich. Der Thermistor ist also Gut.

Danach einfach mal die Spannung am Spannunsgteiler messen, das sind bei 200°C bei mir 3,2V.

Den Wert den der ADC daraus macht errechnet sich dann mit:

adc_wertDie 5V im Zähler des Bruches, sorgen dafür das man direkt den ADC Wert für die thermistortables bekommt, mit denen Marlin rechnet. Marlin rechnet bei einem ADC-Wert von 0 mit der maximalen Temperatur und bei 1023 mit der mininmal Temperatur.

Das ergibt dann bei mir einen Wert von ungefähr 368. Ein Blick in die thermistortables zeigt dann:

THERMISTORHEATER_0 == 51

{366*OVERSAMPLENR, 200},

Marlin rechnet also mit einem ADC Wert von 366 für 200°C, passt also ganz gut. Wenn die Werte nicht gut zusammenpassen einfach die Thermistortabelle auswählen die am besten passt.

Folglich ist sowohl Marlin, als auch der Thermistor korrekt, ich verliere einfach auf dem Weg zur Düse etwas Wärme. Also entweder isolieren oder die Temperatur unter Berücksichtigung des Offsets höher drehen.

… dann ist der Idler ist gebrochen, und natürlich mitten im Druck. Anscheinend hatte ich den wohl zu fest angezogen, und das Material hat es dann nach einer gewissen Zeit nicht mehr ausgehalten.

idlerImmerhin hatte ich für manche kritischen Teile schon einmal Ersatz gedruckt, so das noch ein Idler in meiner Kiste lag.

P1060772Nicht die beste Druckqualität, da das Teil noch zu einigen meiner ersten Drucke gehört hat (Layerhöhe 0,4mm und Flowrate noch nicht ordentlich eingestellt), aber damit kann ich wieder Drucken.

Was lerne ich daraus: Idler nicht so brutal festziehen, vielleicht versuche ich es ja mal hiermit., das ist eine ganz nette Idee, würde das auf- und zuschrauben beim Filamentwechsel vereinfachen, auch wenn ich mir nicht sicher bin ob das dauerhaft den selben Druck auf das Filamnet ausüben würde. Aber da geht Probieren über Studieren, werde ich für den nächten Extruder (Zweifarbig drucken wäre klasse) den ich gerade am bauen bin mal Testweise verwenden.

Tipp des Tages also: immer ordetlich Ersatzteile dahaben.

Mein Extruder saß ursprünglich mit den Zahnrädern in Richtung des Antriebszahnriemen, das heißt immer wenn man an die Transportschraube fürs Filament rankommen wollte, musste man den Zahnriemen abspannen und danach wieder aufspannen. Mühselig!

Also wurde das jetzt endgültig umgedreht, dafür musste zwar die Grundplatte modifiziert werden aber nun sitzt der Extruder „richtig“ rum.

extruderWie man auf dem Bild auch noch sieht habe ich dem Motor zwei kleine Kühlkörper spendiert, der wird zwar nicht übermäsig heiß, aber ist wohl doch der wärmste Motor im 3D Drucker. Ich habe diese einfach mit einem Kabelbinder grob fixiert und dann mit Arctic Silver Wärmeleitkleber festgeklebt.

Und da ich schon dabei war haben auch noch die anderen Motoren je einen Kühlkörper bekommen.

KueKoeWie viel das bringt kann ich noch nicht sagen, da der Rest von Drucker zur Zeit noch Still steht. Vorher wurde dieser Motor bei Drucken um die 50°C warm, später werde ich mal nachmessen.

In recht mühervoller Arbeit ist meine neue Transportschraube entstanden:

schraubeMan sieht auf den Bild zwar kaum einen Unterschied aber die obere Schraube ist die neue. Jetzt aus VA Stahl in der Hoffnung das das länger hält, es sei denn der Endanwender, also meine Wenigkeit, macht die Schraube aus Schusseligkeit kaputt, deshalb ist ja eine neue auch überhaupt notwenig gewesen.

Hoffentlich denke ich an die Arbeit die mich das neue Ding gekostet hat, wenn ich damit hantiere. Filament läuft jetzt jedenfals wieder prima.

Da ich eh mal wieder ein bisschen am rumexperimentiern war und dabei auch zwei Kabel ausgewechselt habe, die gebrochen ware (zu viel Bewegung), habe ich die Gelegenheit genutzt und mal nachgemessen was am Drucker vieviel Strom braucht. Eine grobe Kalkulation hatte ich schon einmal hier gemacht, das sind jetzt aber dann die gemessenden Daten.

Heizbett

  • Betriebsspannung: 26,3V
  • Stromaufnahme unter Volllast (ohne PWM): 8,3A
  • Leistung: 218W (0,44W pro cm²)

Arduino Mega 2560

  • Betriebsspanung: 12V
  • Stromaufnahnahme während des Druckes: 0,08A
  • Stromaufnahme während des Druckens mit Smart LCD controller: 0,29A (die LCD Beleuchtung frisst recht odernltich Power)
  • Leistung: 1W (wobei über 50% der Leistung in dem 5V Spannunsgregler verbraten werden)
  • Leistung (mit Smart LCD controller): 3,5W (gilt hier natürlich auch)

RAMPS inklusive Motortreiber und Motoren

  • Betriebsspannung: 27V (da gibs weniger Verluste in den Kabeln, hängt alles an dem selben Netzteil)
  • Stromaufnahme alle fünf Motoren unter Strom: 0,7A
  • Stromaufnahme beim Drucken (gemittelt über 5 Minuten): 0,47A
  • Leistung: 19W
  • Leistung beim Drucken: 12,7W

Extruder (nur Heizleistung, Motor wurde bei RAMPS mitgezählt)

  • Betriebsspannung: 26,8V
  • Stromaufnahem (bei zwei 6,8 Ohm Widerständen in Reihe): 2A
  • Leistung: 54W

Maximale Gesamtleistung: 293,8 Watt

Ich drucke mit einem Extruder von reprap-fab.org, der Extruder ist klasse, erlaubt schnelles drucken von ABS (150mm und mehr) und ist leicht auseinander zu nehmen.

Aktuell muss ich die Düse reinigen da mir wohl noch etwas Staub von dieser Aktion hier, in den Extruder geraten ist und die Düse verstopft ist. Das reinigen an sich ist recht einfach, einfach den Extruder aufheizen und die Messingdüse rausdrehen. Diese ist dann voller ABS was sich recht einfach mit Aceton lösen lässt. Ich stecke die Düse einfach in in kleines Fläschen voller Aceton und nach zwei bis drei Tagen hat sich das ABS gelöst.

Wem zwei Tage zu lange sind (weil man keine andere Düse hat und Druckprojekt doch grade so gut läuft) kann es mit Bewegung probieren. Ich kleb das Fläcshen dazu einfach auf einem Motor und lass das ganze langsam vor sich hindrehen und schwups geht das schneller. Natürlich kann man versuchen auch mechanisch dem ABS zu leibe zu rücken, dabei aber aufpassen die Düse nicht zu beschädigen. Ich überlasse das lieber dem Aceton.